Backtesting Data Loading Issue in Version 1.135.3 in Seconds and Ticks Base Periods

Hi @Mod-JakeM,

I downloaded version 1.135.3 which would be the latest version.
But if I want to load the default backtesting in seconds for the September time frame, it doesn’t work.

I attach an example for the period from September 18 to September 22 for the symbol NQ.Z23 and base period in seconds. The test seems to run fine, but it does not load any data from the symbol.

I can replicate this from September 11 to October 19, which if we see in the graph clearly there is volume of data (for data prior to September 11 also happens but I ignore it because the volume is much lower).

Then from October 20th onwards it seems that the data are loading.

It is a bit strange because this happens for the data in seconds and ticks, for the cases of the base period in minutes and days everything works fine in any date period.

And it is not something particular to this symbol, I also checked it with the ES.Z23.

Could you confirm me if this is a bug, and an estimated time of when it would be fixed, and I tried to downgrade to an older version and I have the same problem.


Hi @fermilans,

Thank you again for your post! We always appreciate your feedback.

This is something we will likely need to test a bit more and get back to you on. In your second picture, I am unable to tell, but did you test this data using the market replay feature?

For troubleshooting purposes and to test consistency, I would be curious to see what happened if you loaded this date range using our MaR - Market replay feature to load the same exact date trading as your backtest.

Please click the Optimus flow logo in the top left of your screen and scroll down to the green section of buttons where you will find the market replay feature:

You can configure the market replay window with the exact parameters as you have in your backtesting window:

And once data loads, click on the visualizer and open a chart through it as shown below:

I am curious to see if your market replay feature behaves the same way as backtesting with your account. For me personally, I am not having any issues with the market replay - so additional updates may need to be made to backtesting, however, I would ask you to check as well since you observed this with backtesting on your account.

Here are my in progress market replay results and it seems to be ok for me:

Thank you for helping us troubleshoot and please let us know what happens with market replay. In the meantime we will show our developers this post for their feedback as well.

Optimus Futures Support

Hi @Mod-JakeM , how are you?

Thanks so much for the quick response and clear instructions! It’s great to see that my reports are taken seriously.

I tried what you indicate and I see a couple of problems, in the case you show me I could play it and it works fine:

The failure comes on the side when “base period” is set in seconds, and I can reproduce the error, i.e. the market replay is executed, but the data is not loaded. And in “base period” with tick doesn’t work either.

I seem to have become an unwitting bug hunter :sweat_smile:. I just noticed another small detail in the market replay: when selecting “base period” in seconds and “type” Last, the system shows “type” “BID” and “TimeFrame” “1 minute” (as you can see in the attached image). It seems to me that it is the label anyway. Could it be that I have a bug magnet?

If you prefer, I can create another post for this bug and not make a mess here, I hope I’m not becoming a nuisance with so much reporting!

I hope I have been clear with my explanations. If you need more details or any clarification, please don’t hesitate to let me know, I’m here to help.


Hi @fermilans,

I am doing great thanks for asking, I hope you are doing well too.

You are very welcome on the response, we would love to get this resolved for you. Your feedback is very helpful and thank you for taking the time to troubleshoot with us over the market replay feature.

No need to create another post for now, let us start with investigating the additional feedback you’ve given us here with our developers and we will follow up on this post as soon as we know more. If we need any additional clarification about your explanations or need additional feedback, we will follow up with you in the meantime!

Thank you again for your persistence and willingness to help us resolve this.
Optimus Futures Support

1 Like

Hi @Mod-JakeM , how are you?

Now it is happening to me with the recent data of CL.Z23, they do not load the data from 21 to 27 November, as you can see in the test, it arrives until the 20th.
This is in the “market replay”, and in the “backtest & Optimize (beta)” it also happens.

This is the configuration that I set up:

Checking the logs, it seems to be throwing exception.

I hope this will be more helpful in identifying the problem.


Hi @fermilans,

After discussing this with our developers further, this seems to be a result of the data feed you are using, how seconds data is calculated on this feed and the speed at which is being received from the server.

If the native data feed being used by the client does not support seconds data, our developers build the seconds data locally so the user can use second timeframe charts and use backtesting on seconds data.

From what I can gather, in my opinion, it seems the latest issues you are having with the backtesting function seem to be stemming from the fact that tick data is limited with the data feed you are using and further, seconds data is not native to this feed and is being calculated locally.

Although these time frames may work with realtime data or even market replay normally without much adjustment, please keep in mind that you or the platform might have previously saved data in your local cache which could be pulling in data from your local machine rather than the server. According to our developers, when using backtesting, to do the correct test and ensure that the data is not coming from local cache you need to use the “Reload from server” option.

Our developers are also addressing something with the data providers in regards to the speed of data queries with tick data which may potentially improve on this as well. They have observed that the download speed of tick data when using this data feed loads fast initially, but slows down after about 5,000 ticks which could be part of the reason why you are encountering this with even such a small number of days being loaded.

Ultimately from what I have gathered and based on our developer’s feedback, if you continue to use backtesting feature with automated strategies - you may need to consider using a different data feed that supports Seconds time frame natively, try reloading history (server) to ensure the data is being received from the server rather than from local cache, or try using a different base period than seconds.

I hope this feedback and the alternatives we provided help and give you a few things to consider about how to navigate this function moving forward. Thanks for your understanding as well as we continue to look into it.

Optimus Futures Support

Hi Jake, how are you?

Thanks for the detailed explanation. I understand the challenges related to the seconds data feed and the limitations of backtesting in our current setup. Could you recommend me some alternative data feed sources that natively support the seconds timeframe? Just to keep this in mind.
I appreciate your help on this matter.


If someone is in the same situation I found this other way, Considering that the method is marked as deprecated, but hey, it works. :

1 Like

Hi @fermilans,

Thanks for your patience on response time.

For alternative data feeds, you could consider the Rithmic data feed instead which does support second time frames natively.

And thank you for posting the image about the alternative solution you found - this could be helpful to other users in the same situation.

Optimus Futures Support

1 Like