Help Center Blog Open An Account

Price Ladder Trading

Hi,

I believe there should be an adjustment to Dom Trader. When placing a sell/buy limit order the operation works as expected.

When placing an initial buy/sell order as a stop, you hold down shift then left click. However, as in the photo, it shows LMT instead of STP.

The order does place correctly but there is no confirmation of this (confirmations off due to the way I trade), which makes one nervous as if it is placed as LMT you’d be filled (likely) immediately.

I’d say that changing from LMT to STP when the left shift key is held down is essential or if you are buying and placing an order above the bid it could automatically switch to STP, which would be optimal in my opinion.

Hello @Embassy5,

Thank you very much for bringing this to my attention. This is something we’ll need to investigate and look into.

Are you currently running the most up to date version of Optimus Flow: Version 1.118.5?

If you aren’t sure, you can check and update your platform by clicking the “recycle icon” in the top right tray of the Optimus Flow platform. If this “recycle icon” is green, this means you have an update.

See the image below for the icon I am referring to:

image

Also, are using a Rithmic demo account? Or is this a live account?

Please let us know if your platform is fully updated and the account type you are currently using, this will help us with addressing the issue as well.

I am currently testing this and I am not encountering this issue like you are. Does this happen if you hold shift on your keyboard for more than 3 seconds? As you can see in the image below, my DOM is clearly labeling the order type as STP after I hold down the shift button on my keyboard:

Any other info would be helpful!
Thanks,
Jake
Optimus Futures Support

2 Likes

Hi,

The platform is on 1.118.5 and is up to date. Windows 11 is up to date.

Glad to hear this is not expected behavior. I am currently using the Rhythmic trial, I bet this will clear up once my live account is connected. Will keep you informed.

Thank you,

Christopher

It happens regardless of the price and how long I hold down shift. I can be in for a buy,
be below the bid, hold shift move above bid and same.

Intermittently, it does AFTER placing the order, move to STP. This has only happened once after placing the order. I have not gotten it to change to STP before placing the trade.

Yet, I will wait to work on it more with the live account should it persist.

1 Like

Hi @Embassy5,

Thank you for the additional feedback.

Would you mind trying to open a new DOM - Depth of Market Window for me?

After you open a new DOM, try following this procedure again. Do you notice any difference?

There may be some sort of graphical issue with the DOM in your original workspace. I’d be curious to see what happens if you use a new DOM panel.

Please let me know!
Thanks,
Jake
Optimus Futures

1 Like

Hi Jake!

I wiped the computer completely reinstalled the Os’s (needed to anyway).

Installed OPTIMUS FLOW and did the update. Restarted, opened OPTIMUS FLOW, it connected to the delayed rhythmic data and default platform loaded. Did not reinstall settings. Same issue.

Found the issue though. -------

When pressing “Shift” Parallels does not send the “Shift” to the Win 11 VM. So I mapped the F5 key so parallels changes it to “Shift” in Win 11 and the issue is resolved. Thanks for letting me know it was just me.

No idea why Parallels doesn’t send Shift unless combined with another key or mapped to a non control key. But I’ll let Parallels know so they can hopefully include in an update.
Screen Shot 2022-03-17 at 3.44.07 PM

1 Like

Note - Would love to see it switch from LMT to STP without a key press. Perhaps a key press to get back to LMT if below/above bid/ask? If one wants market instead of limit buy above bid then the market key is very close by.

And the best thing about Jigsaw Daytradr is that if you are in with a TP and SL is when you click on the price it will move the TP or SL to the location you clicked depending if you are long or short. Love to see this on OPTIMUS FLOW.

1 Like

Thank you very much for following up and letting us know why this occurred.

This is great to know for other Mac users using parallels who may encounter this down the line!

Thank you for your suggestion as well, we can gladly suggest this to our developers to improve on the current experience with placing stops through the DOM.

Best,
Jake
Optimus Futures Support

1 Like