Help Center Blog Open An Account

Unable to visualize Optimus Flow on my brand new PC

I’ve been trying all sort of things to try to run Optimus Flow but nothing works.

I get the next error since the beginning. I get a blank window like this in the OAuth window, where you sign in to your account:

When I should be looking at this:

At first I was adviced to fix the Windows Time Synchronization Error, but fixing that didn’t solve my problem. I keep on getting the same blank window when I open Optimus Flow.
So the Dell Support Team sent me a brand new hard disk unit with the latest Windows 10 version, because they thought there was an issue with my brand new laptop, but that didn’t help at all. The issue keeps on happening.

So I downloaded the platform in my brothers laptop, which also has the Windows Time Synchronization Error, and to my surprise, the platform runs without any issue.
As you can see on the next image, I’m running the platform, I’m connected to Rithmic Data and the Windows Time Synchronization Error is framed in red on the right side of the image in the Time and Zone window.

So what I did next was to disable the whole Windows Antivirus and Firewall and make sure Optimus Flow had every type of system permission it could need, but that didn’t change a single thing. I keep on getting the same blank window from the start.

What I did next was to ask for help from an IT support technician I know and he helped me verify the log of the application in order to find any issue about the time sync, but we discovered that the time sync is working pretty fine, but it’s still showing some other errors, as you can see next:
Time Sync Ok:

New log error:

As you can see in the screenshot, the error that is being shown is related to an error in the application, not in my windows instalation.

What he did next was to verify that the “.net” is already installed, and it was, with the latest version.
So the issue has to be related to a missing configuration. Or maybe the developer it’s not providing a driver for the newest version of Windows 10.

This is my Windows 10 version, the latest one:
Windows 10 Pro, version 20H2, build 19042.844, Windows Feature Experience Pack 120.2212.551.0

And my brother’s versions, the one that can run Optimus Flow, is:
Windows 10 Pro, version 1909, build 18363.1379

Before all of this happened, I downloaded another Quantower developer’s version. And it showed the same issue but with an exception. At first every window is showned blank like on Optimus Flow, but when I minimize the window and then I maximize it, I finally get to see the window as I’m supposed. But this wasn’t practical at all for trading, so I moved on and this was when I started trying to use Optimus Flow.
Unfortunately I don’t have screencaptures of this because it was downloaded before my hard disk unit was replaced and since it wasn’t working, I didn’t made a backup of it.

Back to the topic, I really need your help with this issue and maybe even Quantower’s help.

I emailed @Jake Montag about this, but since this seems to be the first time this has happend and nothing seems to work, I think it has to be documented in the forum.

Could you please help me verifying if the configuration in the computer it’s the correct one, and also check if all the required files and application are already installed?

Could you please remove any other white label software version you claim was built by others, I have removed any other references to that company as well. Once you remove them, please try to run Optimus Flow version again. Maybe different versions create conflicts.

Let us know if that helped.

Matt Z
Optimus Futures

There’s not another white label software version in my laptop. My hard disk unit was replaced and in this new one I have right now, I never downloaded that other version.

Optimus Flow continues to behave the same way when I open it.

Hi @EduardoAguirre,

Thanks for your post and contribution to the community forum.

I know we have communicated via email and although I suspected this to originally be an issue with your PC’s time zone, it appears something else is causing this issue.

I am still waiting to hear back from our developers on what else could be causing this and as soon as I find out, I will let you know and update this thread.

Thanks for your feedback.
Jake
Optimus Futures Support