Problem with the execution of Strategies in version 1.135.2 of Optimus Flow when using 'Base Period' in Seconds

Hello, @Mod-JakeM
I am experiencing a problem with the latest version of optimus Flos, the 1.135.2. And it is happening to me as shown in the following image:

It doesn’t let me execute the strategy, even with the default “Simple MA Cross strategy” when in the Settings, I set “Base period” → Second. It seems strange to me because in the previous version, the 1.134.2 works perfect this configuration, can you confirm me if it is a bug?

Hi @fermilans,

Thanks for reaching out and I hope all has been well. I wanted to let you know that we are checking in with our developers about this.

Just to confirm, before update 1.135.2, you were able to execute this same exact strategy using a second time frame?

Have you by any chance tried any other time frames using this strategy such as a minute or hourly base period?

I will follow up on this post as soon as our developers get back to me about this, but in the meantime, if you could try a different base period for this strategy for troubleshooting purposes, I would be curious to see what happens.

Please let us know and thank you for the post. We will respond as soon as possible.

Optimus Futures Support


Yes, I tested it with minute period, and even with smaller period as tick. In both cases it works perfectly. It seems that it is only the period of seconds that does not work. I even tried with another product like MNQ and it gave me the same results, with the same tests.

In version 1.134.2, all available time frames (seconds, minutes and days) work.

Hi @fermilans,

Thank you again for following up and providing additional details.

We are ultimately waiting to hear back from our developers about this. I’ve sent them the forum post and details about the issues you are having. We are trying to replicate this ourselves.

As soon as we know more, we will follow up on this post.

Thanks for your patience while we look into this,
Optimus Futures Support

1 Like

Hi Jake, good morning, how are you?

Have you made any progress with this issue? because I was left out of date in the previous version because of this particular problem.


Hi @fermilans,

Our developers actually got back to us this morning about this and found the issue.

They have confirmed that the Issue was fixed. There will be a fix coming in a minor update that is set to be released by this weekend.

When you see the new update appear, please download it and this should be resolved. You should see the update available and downloadable no later than this weekend.

Thanks for your patience while we looked into this.
Optimus Futures Support

Hi Jake, good morning.

Very good news jake, thank you very much for the help, I will update it over the weekend, and update this post.

Have a nice day :slight_smile:

Thank you @fermilans !

If for whatever reason the issue persists, let us know. Have a great day as well!

Hello everyone,

I downloaded version 1.135.3 and it seems to work with all time periods (tick, seconds, minutes and days), both for the default strategy and for my personal ones.

I also leave attached another problem that I noticed when I wanted to load older data, and I leave it loaded in the following post: Backtesting Data Loading Issue in Version 1.135.3 in Seconds and Ticks Base Periods - Futures Trading Platforms / Optimus Flow - Optimus Futures Trading Community



Thank you for confirming the update fixed this.

We will address your other post as soon as we can. Thank you again for keeping us updated on your findings, these are very helpful.

Optimus Futures Support

1 Like