Help Center Blog Open An Account

Rithmic User Agreement


#1

Hello Trader,

You might have received this message from our clearing:
The CME’s current market data policies require that a market data distributor maintain its own records on all market data subscribers. As Rithmic is a market data distributor, Rithmic must maintain such records. Consequently all users (market data subscribers using Rithmic’s software and market data) must agree to and sign Rithmic’s Market Data Subscription Agreement and all users must self-certify their status as a Professional Subscriber or as a Non-Professional Subscriber.

Agreement to Rithmic’s Market Data Subscription Agreement and Market Data Subscriber Self-Certification must be made electronically and can only be made through R | Trader™. This means that every user, whether they use a third party trading screen or custom built software must run R | Trader™ and sign the Agreement and make a Self-Certification, even if a user does not use R | Trader™ for anything else. A user who has a log in to more than one environment will have to agree and self-certify in order to be able to log in to each environment (so a user who has access to Rithmic 01 and to Rithmic Paper Trading will have to agree and self-certify twice, once for each environment).
Effective April 25, 2014, any user who has not signed the Agreement and who has not made a self-certification will not be able to log in until they have signed and certified. The best way to sign the Agreement and to make the self-certification is to download R | Trader™ version 12.16.0.0 from http://www.visionfinancialmarkets.com/Services/platforms/RithmicTrader.msi.

Should you have any questions, please contact our trading team at support@optimusfutures.com

**Some of the questions that I was asked:

  1. “Is this for people who use R-Trader only.” The answer is no. This is for any trader that uses the Rithmic Data Feed

  2. “Which credentials do I use to log in”? The same ones you use to access your platform that uses the Rithmic data feed.

  3. “What will I see once I download the platform and log-in?” You should see a this:**

Both will be red in your case, but the minute you click on it and agree to the terms by scrolling down, it will turn green. Please do agree to both links.

If you have more than one user ID for Rithmic, you would have to login with each ID.
This is in the event you use a number of platforms driven by Rithmic.

Please let us if we could be of further help. Please register on this forum if you have additional questions you would like to ask.

Kind Regards,

Matt
Optimus Trading Group
Online Futures & Commodity Trading, Discount Commodities Broker Rithmic Feed Broker


#2

You may view a video tutorial of process here:

[video=youtube_share;XjrlUvG73f8]http://youtu.be/XjrlUvG73f8[/video]

Click Here To Download R Trader


#3

There are no agreements when I launch the Agreements link. I don’t use R Trader, fyi, I use Ninja. Is this going to be a problem?


#4

Whether you use R-Trader or any other screen like NinjaTrader that uses the the Rithmic data you need to agree to agree to the terms. I had a few more users that have encountered the same issue as you, so I will inquire with Rithmic what is the issue.

Matt


#5

Same here. I get no Agreements and the Agreement screen is blank when I use the ‘File’ tab in the upper left corner of Rithmic Trader.


#6

I also do not have any agreements to accept when I log into R-Trader.

Branden


#7

I apologize for all the problems some users are having. It is rather puzzling that some users see all the agreements and some see a blank if at all. Just as a reminder, everyone must use a R | Trader 12.16.0.0

I have provided a ink here from the Rithmic site for the download:
https://rithmic.com/rtrader.msi

I hope this helps certain users.

Matt


#8

Hello,

same here, no agreements displayed. Also didn’t receive that email from Vision. My version is OK.


#9

Downloaded latest R-Trader

No agreements listed


#10

Same here. Looked like the same version, but I uninstalled the first app and reinstalled from the link above. No change.

I should add that I don’t get the agreement list up automatically after login, I have to select Agreements from the File-menu, but then the list is empty.


#11

An additional piece of information that could be useful is that Rithmic supports only Windows 7 and Windows 8.
Is that what you guys are using?

Matt


#12

On the self certification at bottom under non professional subscriber says " By clicking on the button below labeled “Non-Professional” and then clicking the on the button labeled submit"

Problem is there is no button to choose either Non- Professional or Professional. All you can do is click “I accept” on the agreement. So I clicked “I accept” and it shows agreement accepted but how will they know if we are non professional or proffesional since there was nothing to choose?


#13

I will keep posting updates here so I can help everyone to resolve this. I am in touch with Rithmic and the trading Desk @ VFM.
Thank you for your patience.

Matt


#14

@Mod-Mattz I was able to get the buttons to show so can choose either professional or non professional by installing latest version r trader. But since I have already accepted the agreement it will not let me choose either non professional or professional. Essentially my agreement was submitted with neither checked. How do I get reset so can declare and resubmit?


#15

Good Q. W
e are working now with the trade desk and Rithmic to resolve the existing issues that our customers are experiencing. I will keep you posted shortly about this specifically.


#16

I’m using Win7 and R/Trader 12.16.00. and no Agreements are visible.


#17

Tried myself on a different PC with Windows 7, and the same results. Empty listbox from the Agreements menu.


#18

I downloaded R-Trader and seemed to go fine. Couple questions…
When starting the R-Trader platform, it asks for System and Gateway. Does it matter which options are chosen? Seems to log in no matter which I choose…
After accepting the agreements, is that it? Can I delete the platform from my computer now? Or does this R-Trader platform need to remain open, active, and online while NinjaTrader is open as well?


#19

You can leave the system as 01 and gateway as Chicago Area.
After accepting the agreement you don’t need to maintain R Trader open in order to trade on NinjaTrader.
However, you can use R Trader as your back up and I highly recommend it.

Matt


#20

I’m using Win 8 Pro 64 bit and R-Trader 12.16.00. (New installed) and no Agreements are visible.